
Installation
Installation involves putting a few files in the right place, and knowing what magical 
string(s) your modem needs to be setup correctly.

Put these files in your WINDOWS/SYSTEM directory if they aren't already there:
      VBRUN300.DLL
      COMMDLG.DLL
      CMDIALOG.VBX    

Subsequent steps are slightly different depending on which TCP/IP package you are using.
 
Installation for PC/TCP
Put the remaining files in the PC/TCP directory (the one with PCTCP.INI), except you can 
throw away LOGIN.ORI.

Add a program item in an appropriate group for PCDIAL.EXE.    Make the working or start-
up directory the PC/TCP directory.

Installation for Trumpet Winsock
Put the other files in the directory with TCPMAN.EXE, except throw out DIALBELL.INI and 
COMSCRPT.PIF.
 
If you have a working LOGIN.CMD, save it by renaming it.    ( In case you don't, PSUDIAL 
will copy any existing LOGIN.CMD to LOGIN.SAV before generating a new one.)
 
Add a program item in an appropriate group for PCDIAL.EXE.    Make the working or start-
up directory the same directory as TCPMAN.

PC/TCP Requirements
    For PC/TCP the program needs the following:

- The environment variable PCTCP is expected to point to the PC/TCP INI file;      the 
same directory is expected to have the DIALBELL.ORI file.            

- The COMSCRPT.PIF file is expected for PC/TCP dialing.    

- The PCTCP.INI file needs the appropriate entries for BELL, and the script    name 
DIALUP (indicating file DIALBELL.SCR).    For example:
      
                              [pctcp comscrpt bell]
                              dialup=c:\comm\pctcp\dialbell.scr
                              hangup=c:\comm\pctcp\hangup.scr

Trumpet Winsock Requirements
    For use with the Trumpet Winsock internal SLIP, the program expects the following:

- The file LOGIN.ORI must be in the working or startup directory for PSUDIAL, which 
must be the same directory that Trumpet Winsock expects the LOGIN.CMD file.

- SLIP must be setup correctly.



Multiple Settings Files
When more than one person is using a single machine, it would be annoying to have to 
reset the userid each time.    For this situation, define an icon for each person and give a 
different "ini" file as an command-line argument for each one.      If you are using Program 
Manager, pick the Properties Item from the file menu, and add the file name after the 
command PSUDIAL.EXE in the comand line text box.

When running PSUDIAL, the name of the current settings or ini file can be checked via 
Help/About.



Password
Put your Access Account password in the Password text box.    You can't dial without doing 
that first.    If the Save Password option is selected (it would be checked in the Options 
menu) then this password will be saved (in a scrambled format) so you do not have to 
enter it again.



Access Userid
In the text box labeled "Access Userid" put your Access Account userid.    What is placed 
here will be substituted for the "<Userid>" string when generating a script.

For machines used by more than one user, see "Multiple Settings Files" in the Installation 
section. 



Delete Button
Click on the delete button to remove the saved string that is currently showing.    If you do 
this by mistake, press Cancel and then NO when asked if you want the changes saved.



Entry Name
This is an arbietrary name for a paticular saved entry.    An entry consists of 5 pieces of a 
dialing string and optionally two modem setup strings.      

A list of all saved entries is shown when you click on the down-arrow to the right of the 
text showing the name of currently displayed dialing string.



New Button
Click the New button to duplicate the current entry.    You can then change the values for 
the new entry without loosing the original.



Save Button
Clicking the save button will rewrite the settings file, saving the modem strings, program 
options, and the position of the main window.

 (Pick About from the Help menu to see what settings file is being used.)

If you change any modem settings strings or program options, you will be asked if you 
want to save the settings before the program terminates.    An exception is the location of 
the main window; we don't check to see if the window has been moved, so if you want to 
save the window location, and haven't change anything else, just click the Save button.



Dialing Strings
There are 5 text boxes where pieces of the modem dialing string can be entered.    These 
are usually labeled "Dial Start" and "Dial Part 1", " Dial Part 2", "Dial Part 3", and "Dial Part 
4", but the labels can be customized for a particular saved entry by editing the settings 
file.    See the Advanced topic for more information about this.

(Here, put discussion of dialing commands from Dan's document.)



Modem Setup
The modem setup string can be one set for all saved entries or one set for the one 
particular entry shown.    The radio buttons below this text box indicate which is currently 
displayed.    If an entry does not have its own modem setup string (most won't), the one 
saved for all entries is shown and used.

To change the modem setup string used for all entries that don't otherwise have one set, 
click on the "All entries" radio button and change the text string.

To change or set a modem setup string that applies only to the entry currently displayed, 
click on the "This entry only" radio button before changing the string. 



Cancel Button
Click on the CANCEL button to exit the program without dialing.    If changes were made to 
any saved strings or other settings, you will be asked if you want to save the changes.



Dial Button
Clicking the Dial button will cause the program to edit the skeleton script, creating a new 
one, and launch the appropriate dial program (e.g., COMSCRPT for PC/TCP).    When the 
dialing program is finished, the generated script is ERASED (because it has your password 
in it). 



File Menu
The File menu can be used to Save the current settings (same as the Save button), open a 
different settings file, or add a new string (same as the New button).    Click on one of the 
items below for more information.
Open Settings File
New String
Save Settings



Save Settings
The Save Settings item in the File menu will resave all information to the current settings 
file, usually PSUDIAL.INI found in the current directory.    Equivalent to pressing the SAVE 
button.
Save Button



Options Menu
Use the options menu to change several settings or program options.    Click on one of the 
topics below for more informtion.
Define Modem Setup Strings
Save Password
Minimize After Dialing
Package Installed



Save Password
Select this item from the Options menu to "toggle" a switch indicating the password should
be saved or not.    If the "Save Password" menu item has a check mark to the left of it, then
the password will be saved.

Although the password is saved in a scrabled form that is not readily readable, if your 
machine is accessible by others it is recommended that you NOT have the password 
saved.



Package Installed Option
Select Package Installed from the Options menu to pick which TCP/IP package you are 
using.    See the Installation topic for further discussion of the requirements for each 
package.

Normally, this option will not be necessary to use, as PSUDial detects the TCP/IP software 
installed when first used.    You may need to use this when switching from one package to 
another.



Open Settings File
Select the Open item from the File menu to read a different settings file.    Note that this 
must be a file saved by this program (or one with a valid format).



New Entry
The New String item in the File menu is for adding a new dialing string, and is the same as 
pressing the NEW button.



Advanced Topics
Customized Labels
The labels for the 5 dialing strings can be set for a particular entry by editing the settings 
file (usually PSUDIAL.INI) and entering values for L1=, L2=, etc. with an editor.    Do this 
when PSUDIAL is not running.

The sample settings file provide has an entry with such labels.



Help Menu
Use the Help menu to view the documentation for this program, or, via the About menu 
item, see the version number and author's name.



About Box
Choose the ABOUT menu item in the HELP menu to see the version number and author's 
name.
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Introduction
This program is for entering and saving various dialing strings used to connect to the Penn 
State's "Authenticated Internet Connection" server.    The intended user is one who travels 
often, and needs to dial from various sites with different phone numbers and complicated 
credit card sequences, but can be useful for someone who just switches between two 
different phone numbers.
 
 It can be used with other dialup services.    Only the help files and supplied scripts have 
some terminology specific for PSU's environment.
 
The program allows easy editing of phone numbers and other parts of dialing strings, and 
easy access to a collection of such settings.    When you ask it to "dial", it creates the 
necessary script by reading a "skeleton" file and inserting appropriate characters, then it 
runs    the actual dialing program.    When the connection is made, the generated script is 
erased so your password isn't stored in a file in an easy to read form.    

It is currently capable of working with FTP Software's PC/TCP and Peter Tattam's Trumpet 
Winsock (with its internal SLIP driver). 



Overview
Quick Start
Here is a quick introduction on how to use it.
 
Start the program.    Enter your userid and password.    If your PC is secure and you want it 
to save your password (in a scrambled form), pick the Save Password item from the 
Options menu.

A modem setup string is optional for each saved dial string; if one isn't given a "default" 
string is used.    Set the default modem setup string by selecting "Modem Setup String" in 
the Options menu. 

Pick a dialing string.    Several have been predefined. Change the strings as needed.

Click SAVE.    Click DIAL.
Hanging Up
The program doesn't hang up the phone or severe the connection, because a modifiable 
script isn't need to do that.    Use your "native" TCP/IP functions to do that (e.g., with 
Trumpet WInsock pick BYE from the Dialler (sic) menu.
Efficient Use 
Using the program again is easy.    The last dialing string used is automatically shown.    If 
your pasword is not saved, the pointer is placed password text box, so you can type in the 
password, and press Enter.    Dialing will start.    If your password is saved, then the DIAL 
button has "focus", so just press Enter or click on that button to start dialing.
How it Works
A dialing string is selected from the drop-down list "String Name".    When      the "Dial" 
button is pressed, the program finds a "skeleton" script file,    and substitutes the userid, 
password, modem setup string, and the dialing strings.    (All 5 dialing strings are 
concatenated together.)    It then runs the appropriate dialing program (e.g., COMSCRPT for
PC/TCP), waits for    that to finish, then ERASES the script it generated because your 
password is in it.

In the case of Trumpet Winsock, we don't currently know how to tell when the script is 
done and the connection is finished.    On some systems, trying to erase the temporary 
script results in a trapable error until TCPMAN is done with it, so this is the method used 
when the Minmize option is selected.    On other systems, the program is able to erase the 
script immediately, so TCPMAN is minimized immediately (actually, we wait about 2 
seconds). 



Menus
The menu bar presents the following items:
File
Options
Help



Buttons
There are several buttons in the mail dialog whose function should be obvious.    Click on 
the button name below for more information.
New
Delete
Save
Dial
Cancel



Text Fields
The main dialog has a number of text boxes that can be filled in or edited.    They are:
Access Userid
Password
Entry Name
Start Dialing
Dial Part n
The modem setup dialog has two text boxes for entering modem setup strings.    For more 
information, click on:
Modem Setup
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Modem Setup Switch
The modem setup string usually applies to all saved dialing entries, but a different modem 
setup can be defined for a particular entry by selecting the "This entry only" radio button 
before changing the string.



Modem Setup Option Buttons
All Entries
When this radio button is selected, the modem setup strings shown or changed apply to all
saved dialing entries that don't have their own modem setup strings defined.
This Entry Only
When this radio button is selected, the modem setup strings shown or changed apply only 
to the currently selected dialing entry.    If defined, these strings will be used instead of the 
ones defined for all entries.



Define Modem Setup Strings
Pick "Define Modem Setup Strings" from the Options menu to change the modem setup 
strings used for all entries or the currently selected entry.    An additional dialog box will be 
displayed.



Modem Setup Strings
Enter one or two strings to be transmitted to your modem to initialize it properly for 
communication with the particular package you are using.

This can be the most difficult part because modems differ so much.    More documentation 
and guidelines will be added as we acquire them.



Accept Button
After changing the modem setup strings, click the Accept button to use these settings and 
return to the main dialog.    Note that the changed settings are not saved to disk until you 
click the Save button or answer "YES" when prompted to save settings when the program 
terminates.



Cancel Button
Click the Cancel button to ignore any changes to modem setup strings and return to the 
main dialog.



How to Use Help
This program has context-sensitive help.    With the pointer located on the text box you 
want more information about, press F1.    For buttons and menu items, press F1 while 
holding down mouse button 1.

Help can also be viewed and searched from the HELP menu. 



Disclaimer
Insert standard disclaimer of any liability.    This is freeware.    Use at your own risk.



Minimize Option
This option is only for Trumpet Winsock.

The Minimize option will cause PSUDial to minimize TCPMAN after starting dialing.    (As of 
this writing, this works differently on different systems.    On some systems, TCPMAN is 
minimized after the script is finished.    On others, it is minimized soon after the script is 
started.    We are not sure why.





Default Modem Setup Strings
If you don't know what kinds of commands your modem needs, you can start with this list. 
If your modem is listed, click on the name, and the suggested setup string for it will be 
displayed.    You can further edit that string.

At the time if this writing, many of the modem commands had not been tested and 
verified.    Even if they are certain, differences among system types, telphone service, 
modem versions (within the same model) and COM port types may require changes.






